Варез портал - лучший портал в мире! - Оптимизация MS Windows XP

Оптимизация MS Windows XP
Помещено 15/01/2004 от Fargus

Здравствуйте, уважаемые пользователи WinXP Pro. После установки родненькой вы, конечно же, заметили, как она похорошела по сравнению с 2000-ной. Но!.. Не все пользователи хотят видеть красивости винды и ее (не)навязчивые сервисы, которые добавляют тормозов в нелегкую жизнь простого юзера.

Сегодня я расскажу вам, как избавиться от всего вышеперечисленного. Все описанное ниже вы, возможно, встречали в Интернете и печатных изданиях, я хочу лишь собрать все воедино и донести широкой общественности. Воспользоваться или нет моими советами, решать вам.

Часть первая: оформление
Те, кому не по нраву всякие красивости и навороты интерфейса винды, или же компьютер не позволяет их оставить, читают дальше. Остальные переходят ко второй части. Хотя сам я отношусь к остальным, но все же некоторые элементы оформления я отключил. Вам же посоветую, как полностью избавиться от них.

Первым делом жмем правой кнопкой по таскбару. Свойства — меню Пуск — классическое меню Пуск — ОК.
После этого правой кнопкой мыши щелкаем на пустом пространстве рабочего стола. Выбираем меню Свойства — Рабочий стол — Настройка рабочего стола. Снимаем галочку с Выполнять очистку рабочего стола…, а также с Сетевое окружение (если у вас нет локальной сети). Переходим на закладку Оформление, выбираем Windows Classic style, затем переходим на вкладку Эффекты и снимаем галочку со всего, кроме разве что Отображать содержимое окна при перетаскивании. ОК, Применить. Вуаля! Можно еще зайти на закладку Рабочий стол и поставить Фоновый рисунок в положение Нет.
Запускаем Мой компьютер, в меню Вид ставим Список, в меню Сервис выбираем Свойство папки. В появившемся окне выбираем Использовать обычные папки Windows и избавляемся от лишних украшательств. Переходим на закладку Вид. Ставим галочку в пунктах Не кэшировать эскизы (избавимся от миниатюрных копий графических файлов), Отображать Панель управления в папке Мой компьютер и Показывать Скрытые и системные файлы. После этого жмем Применить ко всем папкам, Да, ОК.
Нажимаем правой кнопкой на иконке Мой компьютер и выбираем меню Свойства (WIN+Break). Выбираем закладку Дополнительно, в меню Быстродействие кликаем по кнопке Параметры. В появившемся окне выбираем Обеспечить наилучшую производительность. После чего нажимаем Применить. Оставить можно только Отображать содержимое окна при перетаскивании, Сглаживание неровностей экранных шрифтов и Отбрасывание теней значками на Рабочем столе.

Часть вторая: службы и сервисы
Уж в отключении служб я поупражнялся;) по максимуму.
Нажимаем магическое сочетание WIN+Break, заходим в меню Восстановление системы и ставим галочку напротив Отключить восстановление системы на всех дисках. Кликаем Применить, идем пить кофе. Восстановление системы — задумка, конечно же, хорошая, но, поверьте, программа Universal Backup справляется с ней намного лучше. После испития целительного напитка возвращаемся и переходим на вкладку Автоматическое обновление и… отключаем его. Кликаем на Удаленное использование и снимаем галочки отовсюду, где они стоят, нажимаем Применить. Далее открываем проводник, кликаем правой кнопкой по иконке диска, на котором стоит система, выбираем меню Свойства и отключаем индексирование диска для быстрого поиска. Снова идем пить кофе. Кстати, возможно, ту же процедуру придется провести отдельно для папок Windows и Program Files.
После этого заходим в папки windows Prefetch и windowssystem32dllcash. Зашли? Теперь удаляйте оттуда все. В папке Prefetch лежат запротоколированные файлы для оптимизации расположения наиболее часто вызываемых утилит, но там же хранятся данные о файлах, которых на компьютере днем с огнем не сыскать (удалили вы их). В папке dllcash — резервные копии системных файлов, предназначенных для восстановления системы.
Теперь идем в гости к msconfig (WIN+R). Здесь мы будем отключать ненужные сервисы и службы. Процесс этот подразумевает некоторую степень риска, поэтому будем осторожны. Заходим в меню Автозагрузка и при большом желании отключаем все. Это на любителя, здесь я не советчик.
Теперь переходим на закладку Службы. Поскольку операции, которые мы будем сейчас производить, несут определенную опасность, я постараюсь описать назначение всех служб. Приступим-с.
Оповещатель — посылает инфу о системных событиях определенным лицам. Отключаем.
Служба шлюза уровня приложения — поддержка сторонних расширений для интегрированного брандмауэра Интернета. Поскольку в дальнейшем мы его отключим, то и эта служба нам бесполезна. Отключаем.
Вторичный вход в систему — позволяет запускать специфические процессы с правами другой учетной записи. Отключено.
Уведомление о системных событиях — служба, занимающаяся рассылкой оповещений о системных событиях подписавшимся компонентам. Можем отключить, но тогда в журнале событий при каждой загрузке системы будет появляться немаленькое количество предупреждений. Не трогаем.
Брандмауэр Интернета, Брандмауэр Интернета (ICF)/Общий доступ к Интернету (ICF) — хотите файрвол, ставьте Outpost. Отключаем.
Диспетчер очереди печати — поскольку есть принтер, оставляю. Если данный агрегат отсутствует, смело отключаем.
Управление приложениями — возможно, принимает участие в процессе установки/удаления софта. Запускается вручную. Оставляем.
Windows Audio — по заверениям винды:), без этого звуку придет смерть. Не трогаем.
Фоновая интеллектуальная служба передачи — для передачи асинхронных данных по протоколу HTTP/1.1. Реальных приложений, использующих данную функцию, отмечено не было. Отключаем.
Сервер папки обмена — дает возможность удаленным пользователям просматривать вашу папку обмена. Отключаем.
Система событий СОМ+, Системное приложение COM+ — от отключения этих служб я воздержался. Не трогаем.
Служба криптографии — проверяет файлы на наличие цифровой подписи. Не трогаем.
DHCP-клиент — это служба, позволяющая компьютеру автоматически получать необходимые сетевые настройки (сетевой адрес, шлюз, адреса серверов имен) с DHCP-сервера. Теоретически нужен для подключения через удаленный доступ. Но ХР прекрасно работала в Интернете и без него.
Служба администрирования диспетчера логических дисков — запуск вручную. Не трогаем.
Диспетчер логических дисков — контроль за внезапным появлением новых логических дисков. Может понадобиться для нормальной работы консоли администратора дисков. Кроме того, при подключении дополнительного винчестера в систему с отключенным диспетчером будет наблюдаться несколько неадекватная реакция. Не трогаем.
DNS-клиент — должен кэшировать ответы на DNS-запросы, но, похоже, это имеет отношение только для сервисов Active Directory. Отключаем.
Журнал событий — ведет протоколирование системных событий. Не трогаем.
Совместимость быстрого переключения пользователей — позволяет менять пользователя, не прерывая запущенных задач. Если вы единственный пользователь, смело отключайте.
Справка и поддержка — без этой службы встроенная справка Windows не работает. Отключать по желанию.
Служба СОМ-записи компакт-дисков IMAPI — если у вас нет пишущего привода, то оно вам не нужно. Если у вас есть пишущий привод, то тогда разве мало вам Nero Burning'a и Alcohol'a 120%? Отключаем.
Сервер — обычно компьютер, предоставляющий общие ресурсы пользователям сети. Отключено.
Рабочая станция — воздержусь, т.к. до конца не понял, что он точно делает. Не трогаем.
Модуль поддержки NetBIOS через TCP/IP — обеспечивает работу SMB-протокола. Отключаем.
NetMeeting Remote Desktop Sharing — если вы не пользуетесь специфическими возможностями NetMeeting, то оно вам не надо. Отключаем.
Координатор распределенных транзакций — кажется, имеет отношение к функционированию ODBC. Не трогаем.
Windows Installer — служба, предназначенная для установки .msi-пакетов. Не трогаем.
Диспетчер сетевого DDE, Служба сетевого DDE — Dynamic Data Exchange — звучит солидно, но в целом бесполезно (за исключением некоторых приложений вроде Сервера папки обмена). Отключено.
Сетевые подключения — без этого сервиса воспользоваться службой RAS не получится. Не трогаем.
Служба сетевого расположения (NLA) — уведомляет приложения об изменении сетевых настроек. Без поддержки со стороны приложений бесполезна. Отключаем.
Поставщик поддержки безопасности NT LM — аутентификация на серверах NT и доступ к ним. Отключено.
Съемные ЗУ — USB, ZIP и прочие. Если таковых не имеется, смело отключаем.
Plug and Play — а без него и не туды и не сюды. Не трогаем.
Службы IPSEC — служит для поддержки шифрования IP-трафика (для специфических заданий по обеспечению безопасного соединения). Отключаем.
Защищенное хранилище — служба, сохраняющая локальные и интернет-пароли. ОТКЛЮЧАЕМ.
Диспетчер автоподключений удаленного доступа — представьте себе такую ситуацию: вы открываете свежесохраненную страницу, а на ней присутствует баннер, который ссылается на другую страницу, и ваш explorer рьяно хочет подключиться к нету. Представили? Вам оно надо? Отключаем.
Диспетчер подключений удаленного доступа — нужная функция. Не трогаем.
Диспетчер сеанса справки для удаленного рабочего стола — а если возьмут, да и помогут:). Отключаем.
Удаленный реестр — позволяет удаленно управлять вашим реестром. Отключаем.
Локатор удаленного вызова процедур (RPC), Удаленный вызов процедур (RPC) — базовые службы. Не трогаем.
QoS RSVP — поддержка специфических расширений IP-протокола. Отнимает 20% интернет-трафика. Отключаем.
Диспетчер учетных записей безопасности — участвует в хранении информации о безопасности для локальных пользователей. Необходим для работы IIS, если он не стоит, то отключаем.
Модуль поддержки смарт-карт, Смарт-карты — они у вас есть? Если нет, то отключаем оба сервиса.
Вторичный вход в систему — позволяет запускать специфические процессы с правами другой учетной записи. Отключаем.
Уведомление о системных событиях — служба, занимающаяся рассылкой оповещений о системных событиях подписавшимся компонентам. Не трогаем.
Определение оборудования оболочки — обеспечивает автоматическое подключение memory cards. По некоторым данным, мешает выполнению chkdsk на подмонтированных томах. Отключаем.
Служба восстановления системы — поскольку мы эту службу уже отключили, то и здесь снимаем галочку. Отключаем.
Служба обнаружения SSDP — узел универсальных PnP-устройств. Некоторые утверждают, что это вполне реальная дыра. На ваше усмотрение.
Служба загрузки изображений (WIA) — если у вас нет сканера или камеры, то этот сервис и так неактивен. Отключаем.
MS Software Shadow Copy Provider, Теневое копирование тома — теневое копирование данных. Синхронизация данных на нескольких ЗУ в бэкграунде. Отключено.
Журналы и оповещения производительности, Адаптер производительности WMI — связано с Perfomance Counters — системой предоставления информации о загрузке памяти, ресурсов, различных устройств и пр. Необходимо лишь для специфического софта (типа MB Monitor). Спокойно можно прожить и без него. Отключаем.
Телефония — нужно для RAS'a. Не трогаем.
Служба терминалов — дает возможность работать на вашем компьютере удаленному пользователю при помощи утилиты Remote Desktop. Отключено.
Темы — так как мы отключили оформление, то и темы нам не нужны. Отключаем.
Telnet — Сервер удаленного управления через командную строку. Отключаем.
Клиент отслеживания изменившихся связей — отслеживает перемещение файлов в пределах локальной сети. Как сказал один человек: "Мобуть, автоматически ярлыки корректирует или что-то в этом духе?" Отключаем.
Диспетчер отгрузки — связано с передачей файлов между клиентом и сервером. Экспериментальным путем доказано, что отключение к летальному исходу не привело (да и назад включить всегда можно;)). Отключаем.
Источник бесперебойного питания — т.к. данный агрегат отсутствует, то отключаю. Если у вас ИБП есть, то не трогаете.
Веб-клиент — что-то для веб-паблишинга, полезных функций (как, впрочем, и вредоносных:)) не найдено. Отключаем.
Инструментарий управления Windows — это Управление компьютером в Администрировании. Не трогаем.
Portable Media Serial Number Service — серийный номер переносного медиа-устройства. Для меня осталось загадкой, для чего винде знать номер, к примеру, моего MP3-плейера? Я поразмыслил и решил, что незачем. Отключаем.
Расширения драйверов WMI (Windows Media Instrumentation) — инструментария управления Windows. Т.к. запуск происходит вручную, трогать не будем.
Беспроводная настройка — автоматическая настройка беспроводных сетей. Отключаем.
На этом мы закончим упражнения по отключению служб и сервисов. Поясню, что данные службы были замечены на моем компьютере. У вас их может быть больше (у меня самого их больше;)) за счет установки нового софта (Outpost, Norton System Work, антивирусы и т.д.).

Часть третья: реестр
В этой части мы будем изменять, добавлять, удалять ветки реестра. Это самая ответственная часть оптимизации, поэтому будьте осторожны. Приступим.
Вызываем regedit (WIN+R, regedit). В появившемся окне первым делом идем к HKEY_LOCAL_MACHINESOFTWAREMicrosoftWindowsNTCurrentVersionAeDebug и меняем значение поля Auto на 0. Так мы избавились от постоянного присутствия Доктора Ватсона (drwatson).
Далее идем в гости к HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesCdrom и по желанию изменяем значение поля AutoRun на 0 (отключаем автозапуск CD).
Идем в HKEY_CURRENT_USERControl PanelDesktop и изменяем параметр MenuShowDelay с 400 на любое другое число (я поставил 50). Этим действием мы уменьшаем (если число меньше 400) или увеличиваем (если больше) задержку перед раскрытием вложенных меню в Пуске.
Если вам не нравятся всплывающие подсказки Windows (Свернуть, Развернуть, Закрыть,), то там же создаем параметр MinMaxClose (строкового типа) и задаем ему значение 0. Ну, а если вы хотите окончательно расправиться с подсказками, тогда идите в HKEY_LOCAL_MACHINESOFTWAREMicrosoftWindowsCurrent VersionExploreAdvancer и создавайте ключ EnableBaloonTips (параметр dword) со значением 0.
В ХР есть функция удаления файла подкачки при выходе из системы. Но если вы не работаете админом сверхсекретной правительственной структуры, то оно вам не надо. Следовательно:
HKEY_LOCAL_MACHINESYSTEMCurrentCon-trolSetSessionManagerMemoryManagment и меняем значение ключа ClearPageFileAtShutdown на 0.
Идем в гости к Unix'у. HKEY_LOCAL_ MACHINESYSTEMCurrentControlSetSessionMa-nagerSubSystem и удаляем ключи Optional и Posix. Обычному пользователю они не понадобятся. Или вы собираетесь запускать Unix-приложения под виндой (которых, кстати, немного)?
Далее направляем мышку в HKEY_CURRENT_USERControl PanelDesktop и копируем содержимое ключей UserPreferencesMask и FontSmoothingType в ветку HKEY_USERS .DEFAULTControl PanelDesktop. Также можно скопировать содержимое ветки HKEY_CURRENT_USERColors в HKEY_USERS.DEFAULT Colors. Так мы добьемся единообразия окраски и оформления после загрузки и при входе в систему.

Часть четвертая: последние штрихи
Сейчас мы будем шлифовать систему для придания ей окончательного товарного вида:).
Направляемся в Диспетчер устройств (WIN+ Break — Оборудование — Диспетчер устройств). В меню Вид выбираем Показать скрытые устройства. После этого в меню Драйверы устройств не Plug and Play мы отключим указанные ниже устройства. Для отключения кликаем правой кнопкой мыши по нужному устройству, выбираем меню Свойства, закладку Драйвер и меняем тип автозагрузки на Отключено.
Отключаем mndm (драйвер MS Netmeeting), NetBios через TCP/IP и RDPCDD (драйвер сервиса Remote Desktop). Перезагружаемся. Данные манипуляции не приведут ни к каким последствиям, т.к. сервисы, от которых зависят эти службы, мы отключили во второй части нашей статьи.
После создания подключения к Интернету идем в Панель управления — Сетевые подключения, кликаем правой кнопкой по имени соединения, выбираем меню Свойства. Переходим на закладку Сеть и удаляем все протоколы, кроме TCP/IP. Остальные протоколы потеряли свою работоспособность после манипуляций во второй части. Перезагружаемся.
Заходим в гости к винде Windowsinf и находим там файл sysoc.inf. Открываем его любым текстовым редактором и удаляем из него все слова hide. Заходим в Панель управления — Установка и удаление программ — Установка компонентов Windows. Все удалить не дадут, да оно нам и не надо. С нас хватит удаления MSN Explorer'a, Windows Messenger'a, а также следующих: Автоматическое обновление (удаление;)) Windows, Другие службы доступа к файлам и принтерам сети (ну зачем, скажите мне, вам нужна Служба печати для Unix?), Очереди сообщений, Сервер терминалов, Служба индексирования, Службы факсов, Средства управления и наблюдения — и, пожалуй, все.
Последним штрихом в нашей работе станет выполнение в командной строке (WIN+R) regsvr32 /u zipfldr.dll. того, что избавит нас от представления zip-архивов в виде папок. Вроде неплохая функция, но у нас же есть WinRAR.
Напоследок заходим в Диспетчер устройств (WIN+Break), переходим на вкладку Дополнительно. Выбираем меню Переменные среды и в окне Переменные среды пользователя для… ставим значение %SystemRoot%/Temp. После этого переходим в меню Отчет об ошибках и ставим галочку на Отключить отчет об ошибках. Иначе после каждого не совсем корректного завершения программ (Ctrl+Alt+Del рулит;)) будет выскакивать окошко с ненавязчивым предложением отослать отчет товарищам мягкотелым. Не следует ставить галочку напротив пункта Не уведомлять о критических ошибках. На этом мы с вами закончим путешествие по миру ХР (но только на сегодня:)).

Продолжение следует...

Fargus
http://octavia-studio.com


404 Not Found

Not Found

The requested URL /themes/ffx69_bluegrey/images/pixel.gif was not found on this server.